Проверка / восстановление / очистка репозиториев (источников приложений) Kali Linux Rolling

Оригинальные источники приложений (репозитории) являются главным залогом здоровья вашей Kali Linux. Предупреждение о том, что изменение/добавление новых репозиториев, как правило, убивает систему есть на официальном сайте. Многочисленный опыт свидетельствует, что огромное количество проблем вызвано ошибками в источниках приложений. Если у вас не работают стандартные инструкции по Kali Linux, которые работают у большинства других пользователей, то 99% причиной этого являются изменённые репозитории.

Самое главное, чтобы в репозиториях была строка:

deb https://http.kali.org/kali kali-rolling main non-free contrib

и не было сторонних источников приложений.

В Kali Linux источники приложений прописаны в файле /etc/apt/sources.list. Нормальным, дефолтным его содержимым для Kali Linux Rolling является следующее:

root@HackWare:~# cat /etc/apt/sources.list

deb https://http.kali.org/kali kali-rolling main non-free contrib
# deb-src https://http.kali.org/kali kali-rolling main non-free contrib

Вы можете проверить, в порядке ли ваши репозитории следующей командой, она так и напишет — всё в порядке или есть проблемы:

if cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main contrib non-free" || cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main non-free contrib"; then echo -e "\n\n\033[0;32mРепозиторий в порядке"; else echo -e "\n\n\033[0;31mПроблема с репозиторием"; fi

Если есть проблемы, то всё исправить можно другой командой:

echo -e "deb https://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list

Эта команда полностью затрёт файл /etc/apt/sources.list и добавит туда одну строчку (вы можете это сделать и вручную — без моих больших команд):

deb https://http.kali.org/kali kali-rolling main non-free contrib

После обновления репозиториев наберите эту команду — она обновит данные о доступных в репозиториях пакетах:

apt-get update

Рекомендуемые статьи:

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (4 оценок, среднее: 5,00 из 5)
Загрузка...

17 комментариев to Проверка / восстановление / очистка репозиториев (источников приложений) Kali Linux Rolling

  1. Алексей Лисицын:

    Здравствуйте! У меня к вам БОЛЬШАЯ просьба помочь мне!

    При запуске таких комманд как cat apt-get update и при запуске терминала это:

    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

    Я пытался поставить драйвера видеокарты AMD (oclHashcat) и пропустил самое главное- AMD сказал, что он не может проверить/установить драйвер что он не подходит и что карта не определена, я же пошел дальше(у меня ноутбук)

    И при апт-гет вот это:ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    Игн:1 http://dl.google.com/linux/chrome/deb stable InRelease
    0% [Соединение с http.kali.org]ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    Сущ:2 http://dl.google.com/linux/chrome/deb stable Release
    0% [Соединение с http.kali.org (192.99.200.113)]ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    Сущ:4 http://archive-3.kali.org/kali kali-rolling InRelease
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/usr/lib/fglrx/fglrx-libGL.so.1.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    Чтение списков пакетов… Готово
    W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11-icons (main/dep11/icons-64×64.tar) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11-icons (main/dep11/icons-64×64.tar) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель DEP-11-icons (main/dep11/icons-64×64.tar) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:1
    W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
    W: Цель DEP-11-icons (main/dep11/icons-64×64.tar) настроена несколько раз в /etc/apt/sources.list.d/google-chrome.list:3 и /etc/apt/sources.list.d/google.list:2
     

    Плиз помогите решить проблему это ОЧЕНЬ ВАЖНО для меня!

     

    • Alexey Alexey:

      Откройте файл /etc/environment

      sudo gedit /etc/environment

      Найдите там и удалите строки:

      export COGL_DRIVER=gl
      export COGL_OVERRIDE_GL_VERSION=1.4
      export COGL_RENDERER=GLX
      export LD_PRELOAD=/usr/lib/fglrx/fglrx-libGL.so.1.2

      Затем откройте файл ~/.xsession

      sudo gedit ~/.xsession

      Там найдите и удалите строки:

      export COGL_DRIVER=gl
      export COGL_OVERRIDE_GL_VERSION=1.4
      export COGL_RENDERER=GLX
      export LD_PRELOAD=/usr/lib/fglrx/fglrx-libGL.so.1.2
      gnome-session

      Это должно убрать хотя бы часть ошибок. Если не помогло или помогло не полностью, напишите здесь.

      • Алексей Лисицын:

        Здрасти, теперь все наоборот, у меня чистая Windows 10, которую ИДЕАЛЬНО под себя настроил, оффициальная=>UEFI тут как тут, выделил Kali Linux 60 ГБ (Пристрастился к линуксу теперь не могу без него) И тут сама проблема: эти 60 ГБ надо превратить в Новый жесткий диск что бы линукс смог благополучно расположиться на нем, а то в прошлый раз GRUB вытеснил Windows 10. Или можно сделать лучше? Ваши идеи, *please

  2. Святослав:

    Вы лучшие! СПАСИБО!

  3. TauJ:

    После произведения вышеуказанных изменений:

    - у Firefox'а съехала крыша напару с Iseweasel. Первый не запускается с постоянно вылетающей ошибкой, у второго  - пропала панель закладок;

    - съехала графика в плане темы ОСи и шрифтов;

    - 867 пакета kali отказывается обновлять:

    Пакеты, которые будут оставлены в неизменном виде:
      adwaita-icon-theme afflib-tools alsa-tools apache2 apache2-bin apache2-data
      apache2-utils apktool apt apt-listchanges apt-utils aptitude aptitude-common
      asleap at-spi2-core avahi-daemon avrdude axel backdoor-factory baobab bc
      bind9-host binwalk bluez bluez-obexd build-essential bulk-extractor bully
      bundler cadaver caribou caribou-antler cheese-common clang colord cowpatty
      cpp crda cups-bsd cups-client curl cutycapt dbus dbus-x11 dconf-editor
      debhelper default-jdk default-jre default-jre-headless dmeventd dmsetup
      dnsmasq-base dnsutils dradis driftnet dsniff eapmd5pass edb-debugger empathy
      empathy-common eog ettercap-common ettercap-graphical evince evince-common
      evolution-data-server evolution-data-server-common ewf-tools exim4
      exim4-base exim4-config exim4-daemon-light exiv2 extundelete file findutils
      firmware-linux firmware-linux-nonfree folks-common fonts-lmodern ftp g++ gcc
      gconf-service gconf2 gconf2-common gcr gdb gdisk gdm3 gedit gedit-common
      geoclue-2.0 ghostscript gir1.2-clutter-1.0 gir1.2-evince-3.0
      gir1.2-gdkpixbuf-2.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0
      gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-2.0
      gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-gtop-2.0 gir1.2-mutter-3.0
      gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-packagekitglib-1.0
      gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-telepathyglib-0.12 gir1.2-totem-1.0
      gjs glib-networking glib-networking-common glib-networking-services
      gnome-calculator gnome-contacts gnome-control-center
      gnome-control-center-data gnome-core gnome-dictionary gnome-disk-utility
      gnome-font-viewer gnome-icon-theme gnome-keyring gnome-online-accounts
      gnome-online-miners gnome-packagekit gnome-packagekit-session gnome-session
      gnome-session-bin gnome-session-common gnome-settings-daemon gnome-shell
      gnome-shell-common gnome-shell-extension-dashtodock
      gnome-shell-extension-easyscreencast gnome-shell-extension-refreshwifi
      gnome-shell-extension-workspacestodock gnome-shell-extensions gnome-sushi
      gnome-system-monitor gnome-terminal gnome-terminal-data
      gnome-themes-standard gnome-themes-standard-data gnome-tweak-tool gnupg
      gnupg-agent gnupg2 gnuplot-data gnuplot-qt gnuradio gparted gqrx
      gr-fcdproplus gr-iqbal gr-osmosdr graphviz greenbone-security-assistant
      gsettings-desktop-schemas gstreamer1.0-libav gstreamer1.0-plugins-bad
      gstreamer1.0-plugins-base gstreamer1.0-plugins-good
      gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
      gtk2-engines-pixbuf gucharmap guile-2.0-libs guymager gvfs gvfs-backends
      gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs hashcat httrack hydra
      hydra-gtk iceweasel ifupdown ike-scan imagemagick-common init-system-helpers
      initramfs-tools initscripts iptables iputils-ping isc-dhcp-client
      isc-dhcp-common john john-data kali-desktop-common kali-desktop-gnome
      kali-linux kali-linux-full kali-menu kismet ldap-utils libaacs0 libairspy0
      libalgorithm-diff-xs-perl libaprutil1 libaprutil1-dbd-sqlite3
      libaprutil1-ldap libarchive-extract-perl libarchive13 libasound2-plugins
      libasprintf-dev libatk-adaptor libatk-bridge2.0-0 libatk-wrapper-java-jni
      libatomic1 libatspi2.0-0 libavahi-client3 libc-bin libc-dev-bin libc6
      libc6-dbg libc6-dev libcairo-gobject2 libcairo-perl
      libcairo-script-interpreter2 libcairo2 libcairo2-dev libcilkrts5
      libclass-c3-xs-perl libclass-load-xs-perl libcloog-isl4 libclutter-1.0-0
      libclutter-gtk-1.0-0 libcomedi0 libcpan-meta-perl libcrypt-ssleay-perl
      libcryptsetup4 libct4 libcups2 libcupsfilters1 libcupsimage2 libcurl3
      libcurl3-gnutls libcurses-perl libdbd-mysql-perl libdbd-sqlite3-perl
      libdbi-perl libdbus-1-3 libdbus-glib-1-2 libdee-1.0-4 libdevel-caller-perl
      libdevel-lexalias-perl libdevmapper-event1.02.1 libdevmapper1.02.1
      libdigest-crc-perl libdigest-md4-perl libdjvulibre21 libdrm-dev
      libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl1-mesa
      libenchant1c2a libevdocument3-4 libevent-core-2.0-5 libevent-openssl-2.0-5
      libevent-pthreads-2.0-5 libevview3-3 libewf2 libexempi3 libfbclient2
      libfcgi-perl libfile-basedir-perl libfile-fcntllock-perl libfluidsynth1
      libfolks-eds25 libfolks-telepathy25 libfolks25 libfreefare-bin libfreefare0
      libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1
      libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1
      libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-rail1.1
      libfreerdp-utils1.1 libfreetype6 libfreetype6-dev libgadu3 libgail-3-0
      libgail-common libgail18 libgbm1 libgcc1 libgconf-2-4 libgconf2-4 libgd3
      libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev libgdm1
      libgfortran3 libgjs0e libgksu2-0 libgl1-mesa-dev libgl1-mesa-dri
      libgl1-mesa-glx libglapi-mesa libgles1-mesa libgles2-mesa libglib-perl
      libgmp-dev libgmp10 libgmpxx4ldbl libgnome-bluetooth13 libgnomevfs2-0
      libgnomevfs2-common libgnomevfs2-extra libgnuradio-baz libgnustep-base1.24
      libgnutls-openssl27 libgoa-1.0-0b libgoa-1.0-common libgoa-backend-1.0-1
      libgomp1 libgphoto2-6 libgs9 libgs9-common libgstreamer-plugins-bad1.0-0
      libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin
      libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-dev libgtksourceview-3.0-1
      libgucharmap-2-90-7 libgvc6 libgxps2 libharfbuzz-dev libharfbuzz-gobject0
      libharfbuzz-icu0 libharfbuzz0b libhivex-bin libhtml-parser-perl libhttrack2
      libintl-perl libitm1 libjack-jackd2-0 libjavascriptcoregtk-1.0-0
      libjavascriptcoregtk-1.0-dev libjavascriptcoregtk-3.0-0 libjpeg-turbo-progs
      libkpathsea6 libldap-2.4-2 libldb1 liblircclient0 liblist-moreutils-perl
      liblocale-gettext-perl liblsan0 liblvm2app2.2 liblvm2cmd2.02 libmagic-dev
      libmagic1 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra
      libmagickwand-6.q16-2 libmission-control-plugins0 libmm-glib0 libmodplug1
      libmoose-perl libmotif-common libmozjs-24-0 libmozjs185-1.0
      libmpeg2encpp-2.1-0 libmplex2-2.1-0 libneon27-gnutls libnet-dbus-perl
      libnet-pcap-perl libnet-rawip-perl libnet-ssh2-perl libnet-ssleay-perl
      libnetpbm10 libnm-glib-vpn1 libnm-glib4 libnm-gtk-common libnm-gtk0
      libnm-util2 libnss-myhostname libobjc4 libofa0 libopenal-data libopenal1
      libopenvas8 libpackage-stash-xs-perl libpackagekit-glib2-18
      libpadwalker-perl libpam-systemd libpango-1.0-0 libpango-perl libpango1.0-0
      libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0
      libparams-classify-perl libparams-util-perl libparted-fs-resize0 libparted2
      libpcre3 libpcre3-dev libpcsc-perl libpeas-1.0-0 libpkcs11-helper1
      libpod-readme-perl libpoppler-glib8 libpoppler-qt4-4 libpq5 libproxy-tools
      libptexenc1 libpulse-mainloop-glib0 libpulse0 libpulsedsp libpurple0
      libpython-dev libpython-stdlib libpython2.7 libpython2.7-dev
      libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqmi-proxy
      libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-dev-bin
      libqt4-help libqt4-network libqt4-opengl libqt4-opengl-dev libqt4-qt3support
      libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
      libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns
      libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5
      libqt5test5 libqt5widgets5 libqtcore4 libqtdbus4 libqtgui4 libqtwebkit-dev
      libqtwebkit4 libquadmath0 libqwt-dev libradare2-dev libresid-builder0c2a
      librtmp1 libsane libsane-common libsasl2-2 libsasl2-modules libsdl-image1.2
      libserf-1-1 libsidplay2 libsmbclient libsnmp-perl libsnmp30 libsocket6-perl
      libsqlite3-0 libssh-4 libstdc++6 libsub-identify-perl libsub-name-perl
      libsybdb5 libsystemd0 libtbb2 libteamdctl0 libtelepathy-farstream3
      libtelepathy-glib0 libtelepathy-logger3 libterm-readkey-perl
      libterm-readline-gnu-perl libtext-charwidth-perl libtext-iconv-perl
      libtext-soundex-perl libtotem-plparser18 libtotem0 libtracker-control-1.0-0
      libtracker-miner-1.0-0 libtracker-sparql-1.0-0 libtsan0 libubsan0 libudev1
      libuhd003 libvariable-magic-perl libvdpau1 libvisual-0.4-plugins libvlc5
      libvlccore8 libvte-2.91-0 libvte-2.91-common libwacom-common libwacom2
      libwayland-egl1-mesa libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwebkitgtk-dev
      libwine libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1
      libwinpr-sspi0.1 libwinpr-utils0.1 libwireshark-data libwmf0.2-7 libwnck-3-0
      libwvstreams4.6-extras libxatracker2 libxm4 libxml-libxml-perl
      libxml-parser-perl libxml2 libxml2-dev libyara3 libyelp0 libzvbi-common
      libzvbi0 linux-image-amd64 lmodern locales locales-all lsb-release lvm2
      magicrescue md5deep mdbtools medusa mesa-common-dev mesa-utils metacity
      metacity-common metasploit-framework mfterm mitmproxy modemmanager
      murrine-themes mutt mutter mutter-common mysql-common mysql-server nautilus
      nautilus-data ncrack ndiff netpbm netsniff-ng network-manager
      network-manager-gnome nfs-common nmap nodejs notification-daemon ntfs-3g ntp
      opensc opensc-pkcs11 openssh-client openssh-server openssh-sftp-server
      openssl openvas-cli openvas-manager openvas-scanner openvpn ophcrack
      ophcrack-cli p7zip p7zip-full pack packagekit packagekit-tools parted
      passing-the-hash peepdf perl perl-base perl-tk phonon-backend-vlc
      pidgin-data poppler-utils postgresql preview-latex-style procps prosper
      proxytunnel pulseaudio pulseaudio-utils pyrit python python-apsw python-apt
      python-cffi python-cryptography python-dbus python-dbus-dev python-debianbts
      python-dev python-flask python-flickrapi python-html5lib python-ldb
      python-m2crypto python-magic python-matplotlib python-matplotlib-data
      python-minimal python-mock python-netlib python-openpyxl python-openssl
      python-paramiko python-pefile python-pexpect python-pil python-pil.imagetk
      python-pip python-pybloomfiltermmap python-pycurl python-pyexiv2
      python-pyregfi python-qscintilla2 python-qwt5-qt4 python-reportbug
      python-samba python-scipy python-service-identity python-svn python-talloc
      python-tornado python-tweepy python-twisted python-twisted-conch
      python-twisted-core python-twisted-mail python-twisted-names
      python-twisted-news python-twisted-runner python-twisted-web
      python-twisted-words python-wheel python-wxgtk3.0 python-yara python-zmq
      python2.7 python2.7-dev python2.7-minimal python3 python3-apt python3-brlapi
      python3-cairo python3-gi python3-gi-cairo python3-louis python3-minimal
      qdbus qt4-linguist-tools qt4-qmake qtchooser radare2 rcracki-mt rdesktop
      rebind recon-ng recoverjpeg reglookup reportbug rsyslog rtkit ruby
      ruby-atomic ruby-dataobjects-postgres ruby-dataobjects-sqlite3 ruby-dev
      ruby-eventmachine ruby-ffi ruby-http ruby-http-parser.rb ruby-httpclient
      ruby-json ruby-msgpack ruby-nokogiri ruby-oj ruby-rspec-expectations
      ruby-rubydns ruby-simplecov ruby-sqlite3 ruby-therubyracer ruby-uglifier
      rygel samba samba-common samba-common-bin samba-dsdb-modules samba-libs
      samba-vfs-modules samdump2 set siege sipcrack skipfish sleuthkit
      smartmontools smbclient snmp snmpcheck snmpd socat speech-dispatcher
      speech-dispatcher-audio-plugins sqlite3 sqlitebrowser sqsh ssldump sslsniff
      sslsplit sslyze stunnel4 system-config-printer system-config-printer-udev
      systemd sysv-rc sysvinit-utils tcpflow telepathy-gabble telepathy-logger
      telepathy-mission-control-5 telepathy-salut telnet termineter testdisk
      tex-common tex-gyre texinfo texlive-base texlive-binaries
      texlive-extra-utils texlive-font-utils texlive-fonts-recommended
      texlive-fonts-recommended-doc texlive-generic-recommended texlive-latex-base
      texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
      texlive-latex-recommended texlive-latex-recommended-doc texlive-pictures
      texlive-pictures-doc texlive-pstricks texlive-pstricks-doc thc-ipv6
      thc-pptp-bruter thc-ssl-dos thin totem totem-common totem-plugins tracker
      tracker-extract tracker-gui tracker-miner-fs tshark tzdata udev udisks2
      uhd-host unar upower usb-modeswitch usb-modeswitch-data usbmuxd util-linux
      vboot-kernel-utils vboot-utils vim vim-common vim-gtk vim-gui-common
      vim-runtime vim-tiny vino vlc vlc-data vlc-nox vlc-plugin-notify
      vlc-plugin-samba vpnc w3af w3af-console w3m waffit weevely wget wine wine64
      winexe wireshark wireshark-common wpasupplicant wpscan x11-apps xbrlapi xpdf
      xprobe xserver-xorg xserver-xorg-core xserver-xorg-input-all
      xserver-xorg-input-evdev xserver-xorg-input-mouse
      xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-all
      xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
      xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
      xserver-xorg-video-neomagic xserver-xorg-video-nouveau
      xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128
      xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
      xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
      xsser yelp zeitgeist-core zenity zenity-common
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 867 пакетов не обновлено.

     - выдал несколько предупреждений типа:

    Устаревшая версия 9.4                                                        
     │                                                                              
     │ PostgreSQL версии 9.4 устарел, но пакет сервера или клиента все ещё          
     │ установлен. Пожалуйста, установите последние пакеты (postgresql-9.6 и        
     │ postgresql-client-9.6), и обновите ваши существующие кластеры  с помощью     
     │ pg_upgradecluster (см. man-страницу).                                        
     │                                                                              
     │ Учтите, что установка postgresql-9.6 автоматически создаст кластер по        
     │ умолчанию 9.6/main. Если вы желаете обновить кластер 9.4/main, то должны     
     │ удалить существующий кластер 9.6 с помощью pg_dropcluster --stop 9.6         
     │ main (см. man-страницу).                                                     
     │                                                                              
     │ Старые пакеты сервера и клиента более не поддерживаются. После               
     │ обновления существующих кластеров, пакеты postgresql-9.4 и                   
     │                                                                              
     │                                  <Ok>     

     

    (это последнее).

    - несколько раз спросил, обносить ли пакет или оставить прежним, было выбрано обновить.

    В результате вопрос: что является нормой, а что проистекло от моих кривых ручек?

    • Alexey Alexey:

      Комментарий попал в спам, поэтому отвечаю только сейчас.

      А у вас точно Kali Linux Rolling? И точно не добавляли сторонние репозитории? («Предупреждение о том, что изменение/добавление новых репозиториев, как правило, убивает систему есть на официальном сайте»).

      И если у вас Kali Linux Rolling, то вы её скачивали с оф.сайта?

    • Алексей Лисицын:

      Вот, восстановка пакетов, авось поможет:

      sudo apt-get --fix-broken install
      sudo rm /var/lib/apt/lists/* -vf 

      sudo apt-get update

      sudo apt-get clean

      sudo apt-get autoclean

      sudo apt-get autoremove

      sudo dpkg --configure -a
      sudo apt-get update

    • Ser9:

      Добрй день! Вы решили свою проблему? Если да то каким образом?

    • Ser9:

      на любую следующую команду мне выдает :

      E: Не удалось получить доступ к файлу блокировки /var/lib/dpkg/lock - open (11: Ресурс временно недоступен)
      E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); он уже используется другим процессом?

       

      • Alexey Alexey:

        Когда система обновляется, то она ставит блокировку, чтобы нельзя было запустить ещё один процесс обновления. Эти сообщения говорят о том, что система заблокирована для запуска ещё одного потока обновлений. Такие ошибки возникаю в следующих случаях:

        • система действительно обновляется или проверяет обновления в фоновом режиме. Если вы только загрузились, то подождите 5-10 минут и попробуйте снова
        • предыдущее обновление было завершено некорректно (например, прервано перезагрузкой) и остались файлы блокировки, хотя никаких обновлений не ведётся.

        Во втором случае просто удалите мешающие файлы:

        sudo rm -rf /var/lib/dpkg/lock

        После удаления файла, может появиться сообщение о блокировке другого файла – удаляйте их все.

        После этого, если предыдущее обновление было прервано некорректно, то система напишет, что нужно сделать (какую команду выполнить).

  4. Columbus:

    Помогите, не работает apt-get update.

    root@KaliLinPc:~# sudo apt-get update
    Игн:1 http://dl.google.com/linux/chrome/deb stable InRelease
    Пол:2 http://dl.google.com/linux/chrome/deb stable Release [1 189 B]            
    Пол:3 http://dl.google.com/linux/chrome/deb stable Release.gpg [916 B]                                           
    Пол:4 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1 431 B]                                 
    Пол:5 http://deb.i2p2.no unstable InRelease [12,1 kB]                                                            
    Пол:6 http://deb.i2p2.no unstable/main amd64 Packages [2 844 B]                 
    Игн:7 http://http.kali.org/kali sana InRelease                                                
    Игн:8 http://http.kali.org/kali sana Release               
    Игн:9 http://http.kali.org/kali sana/main amd64 Packages
    Игн:10 http://http.kali.org/kali sana/main all Packages
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU
    Игн:12 http://http.kali.org/kali sana/main Translation-en
    Игн:13 http://http.kali.org/kali sana/main Translation-ru
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons
    Игн:17 http://http.kali.org/kali sana/non-free all Packages
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU
    Игн:20 http://http.kali.org/kali sana/non-free Translation-en
    Игн:21 http://http.kali.org/kali sana/non-free Translation-ru
    Игн:22 http://http.kali.org/kali sana/non-free amd64 DEP-11 Metadata
    Игн:23 http://http.kali.org/kali sana/non-free all DEP-11 Metadata
    Игн:24 http://http.kali.org/kali sana/non-free DEP-11 64×64 Icons
    Игн:25 http://http.kali.org/kali sana/contribndeb all Packages
    Игн:26 http://http.kali.org/kali sana/contribndeb amd64 Packages
    Игн:27 http://http.kali.org/kali sana/contribndeb Translation-ru
    Игн:28 http://http.kali.org/kali sana/contribndeb Translation-ru_RU
    Игн:29 http://http.kali.org/kali sana/contribndeb Translation-en
    Игн:30 http://http.kali.org/kali sana/contribndeb all DEP-11 Metadata
    Игн:31 http://http.kali.org/kali sana/contribndeb amd64 DEP-11 Metadata
    Игн:32 http://http.kali.org/kali sana/contribndeb DEP-11 64×64 Icons
    Игн:33 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 Packages
    Игн:34 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all Packages
    Игн:35 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-en
    Игн:36 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru                     
    Игн:37 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru_RU                  
    Игн:38 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 DEP-11 Metadata              
    Игн:39 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all DEP-11 Metadata                
    Игн:40 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ DEP-11 64×64 Icons                 
    Игн:41 http://http.kali.org/kali sana/sana/updates amd64 Packages                                                
    Игн:42 http://http.kali.org/kali sana/sana/updates all Packages                                                  
    Игн:43 http://http.kali.org/kali sana/sana/updates Translation-en                                                
    Игн:44 http://http.kali.org/kali sana/sana/updates Translation-ru_RU                                             
    Игн:45 http://http.kali.org/kali sana/sana/updates Translation-ru                                                
    Игн:46 http://http.kali.org/kali sana/sana/updates amd64 DEP-11 Metadata                                         
    Игн:47 http://http.kali.org/kali sana/sana/updates all DEP-11 Metadata                                           
    Игн:48 http://http.kali.org/kali sana/sana/updates DEP-11 64×64 Icons                                            
    Игн:49 http://http.kali.org/kali sana/contrib amd64 Packages                                                     
    Игн:50 http://http.kali.org/kali sana/contrib all Packages                                                       
    Игн:51 http://http.kali.org/kali sana/contrib Translation-ru                                                     
    Игн:52 http://http.kali.org/kali sana/contrib Translation-en                                                     
    Игн:53 http://http.kali.org/kali sana/contrib Translation-ru_RU                                                  
    Игн:54 http://http.kali.org/kali sana/contrib amd64 DEP-11 Metadata                                              
    Игн:55 http://http.kali.org/kali sana/contrib all DEP-11 Metadata                                                
    Игн:56 http://http.kali.org/kali sana/contrib DEP-11 64×64 Icons                                                 
    Игн:9 http://http.kali.org/kali sana/main amd64 Packages                                                         
    Игн:10 http://http.kali.org/kali sana/main all Packages                                                          
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU                                                     
    Игн:12 http://http.kali.org/kali sana/main Translation-en                                                        
    Игн:13 http://http.kali.org/kali sana/main Translation-ru                                                        
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata                                                   
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata                                                 
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons                                                    
    Игн:17 http://http.kali.org/kali sana/non-free all Packages                                                      
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages                                                    
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU                                                 
    Игн:20 http://http.kali.org/kali sana/non-free Translation-en                                                    
    Игн:21 http://http.kali.org/kali sana/non-free Translation-ru                                                    
    Игн:22 http://http.kali.org/kali sana/non-free amd64 DEP-11 Metadata                                             
    Игн:23 http://http.kali.org/kali sana/non-free all DEP-11 Metadata                                               
    Игн:24 http://http.kali.org/kali sana/non-free DEP-11 64×64 Icons                                                
    Игн:25 http://http.kali.org/kali sana/contribndeb all Packages                                                   
    Игн:26 http://http.kali.org/kali sana/contribndeb amd64 Packages                                                 
    Игн:27 http://http.kali.org/kali sana/contribndeb Translation-ru
    Игн:28 http://http.kali.org/kali sana/contribndeb Translation-ru_RU
    Игн:29 http://http.kali.org/kali sana/contribndeb Translation-en
    Игн:30 http://http.kali.org/kali sana/contribndeb all DEP-11 Metadata
    Игн:31 http://http.kali.org/kali sana/contribndeb amd64 DEP-11 Metadata
    Игн:32 http://http.kali.org/kali sana/contribndeb DEP-11 64×64 Icons
    Игн:33 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 Packages
    Игн:34 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all Packages
    Игн:35 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-en
    Игн:36 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru
    Игн:37 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru_RU
    Игн:38 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 DEP-11 Metadata
    Игн:39 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all DEP-11 Metadata
    Игн:40 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ DEP-11 64×64 Icons
    Игн:41 http://http.kali.org/kali sana/sana/updates amd64 Packages
    Игн:42 http://http.kali.org/kali sana/sana/updates all Packages
    Игн:43 http://http.kali.org/kali sana/sana/updates Translation-en
    Игн:44 http://http.kali.org/kali sana/sana/updates Translation-ru_RU
    Игн:45 http://http.kali.org/kali sana/sana/updates Translation-ru
    Игн:46 http://http.kali.org/kali sana/sana/updates amd64 DEP-11 Metadata
    Игн:47 http://http.kali.org/kali sana/sana/updates all DEP-11 Metadata
    Игн:48 http://http.kali.org/kali sana/sana/updates DEP-11 64×64 Icons
    Игн:49 http://http.kali.org/kali sana/contrib amd64 Packages
    Игн:50 http://http.kali.org/kali sana/contrib all Packages
    Игн:51 http://http.kali.org/kali sana/contrib Translation-ru
    Игн:52 http://http.kali.org/kali sana/contrib Translation-en
    Игн:53 http://http.kali.org/kali sana/contrib Translation-ru_RU
    Игн:54 http://http.kali.org/kali sana/contrib amd64 DEP-11 Metadata
    Игн:55 http://http.kali.org/kali sana/contrib all DEP-11 Metadata
    Игн:56 http://http.kali.org/kali sana/contrib DEP-11 64×64 Icons
    Игн:9 http://http.kali.org/kali sana/main amd64 Packages
    Игн:10 http://http.kali.org/kali sana/main all Packages
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU
    Игн:12 http://http.kali.org/kali sana/main Translation-en
    Игн:13 http://http.kali.org/kali sana/main Translation-ru
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons
    Игн:17 http://http.kali.org/kali sana/non-free all Packages
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU
    Игн:20 http://http.kali.org/kali sana/non-free Translation-en
    Игн:21 http://http.kali.org/kali sana/non-free Translation-ru
    Игн:22 http://http.kali.org/kali sana/non-free amd64 DEP-11 Metadata
    Игн:23 http://http.kali.org/kali sana/non-free all DEP-11 Metadata
    Игн:24 http://http.kali.org/kali sana/non-free DEP-11 64×64 Icons
    Игн:25 http://http.kali.org/kali sana/contribndeb all Packages
    Игн:26 http://http.kali.org/kali sana/contribndeb amd64 Packages
    Игн:27 http://http.kali.org/kali sana/contribndeb Translation-ru
    Игн:28 http://http.kali.org/kali sana/contribndeb Translation-ru_RU
    Игн:29 http://http.kali.org/kali sana/contribndeb Translation-en
    Игн:30 http://http.kali.org/kali sana/contribndeb all DEP-11 Metadata
    Игн:31 http://http.kali.org/kali sana/contribndeb amd64 DEP-11 Metadata
    Игн:32 http://http.kali.org/kali sana/contribndeb DEP-11 64×64 Icons
    Игн:33 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 Packages
    Игн:34 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all Packages
    Игн:35 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-en
    Игн:36 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru
    Игн:37 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru_RU
    Игн:38 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 DEP-11 Metadata
    Игн:39 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all DEP-11 Metadata
    Игн:40 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ DEP-11 64×64 Icons
    Игн:41 http://http.kali.org/kali sana/sana/updates amd64 Packages
    Игн:42 http://http.kali.org/kali sana/sana/updates all Packages
    Игн:43 http://http.kali.org/kali sana/sana/updates Translation-en
    Игн:44 http://http.kali.org/kali sana/sana/updates Translation-ru_RU
    Игн:45 http://http.kali.org/kali sana/sana/updates Translation-ru
    Игн:46 http://http.kali.org/kali sana/sana/updates amd64 DEP-11 Metadata
    Игн:47 http://http.kali.org/kali sana/sana/updates all DEP-11 Metadata
    Игн:48 http://http.kali.org/kali sana/sana/updates DEP-11 64×64 Icons
    Игн:49 http://http.kali.org/kali sana/contrib amd64 Packages
    Игн:50 http://http.kali.org/kali sana/contrib all Packages
    Игн:51 http://http.kali.org/kali sana/contrib Translation-ru
    Игн:52 http://http.kali.org/kali sana/contrib Translation-en
    Игн:53 http://http.kali.org/kali sana/contrib Translation-ru_RU
    Игн:54 http://http.kali.org/kali sana/contrib amd64 DEP-11 Metadata
    Игн:55 http://http.kali.org/kali sana/contrib all DEP-11 Metadata
    Игн:56 http://http.kali.org/kali sana/contrib DEP-11 64×64 Icons
    Игн:9 http://http.kali.org/kali sana/main amd64 Packages
    Игн:10 http://http.kali.org/kali sana/main all Packages
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU
    Игн:12 http://http.kali.org/kali sana/main Translation-en
    Игн:13 http://http.kali.org/kali sana/main Translation-ru
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons
    Игн:17 http://http.kali.org/kali sana/non-free all Packages
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU
    Игн:20 http://http.kali.org/kali sana/non-free Translation-en
    Игн:21 http://http.kali.org/kali sana/non-free Translation-ru
    Игн:22 http://http.kali.org/kali sana/non-free amd64 DEP-11 Metadata
    Игн:23 http://http.kali.org/kali sana/non-free all DEP-11 Metadata
    Игн:24 http://http.kali.org/kali sana/non-free DEP-11 64×64 Icons
    Игн:25 http://http.kali.org/kali sana/contribndeb all Packages
    Игн:26 http://http.kali.org/kali sana/contribndeb amd64 Packages
    Игн:27 http://http.kali.org/kali sana/contribndeb Translation-ru
    Игн:28 http://http.kali.org/kali sana/contribndeb Translation-ru_RU
    Игн:29 http://http.kali.org/kali sana/contribndeb Translation-en
    Игн:30 http://http.kali.org/kali sana/contribndeb all DEP-11 Metadata
    Игн:31 http://http.kali.org/kali sana/contribndeb amd64 DEP-11 Metadata
    Игн:32 http://http.kali.org/kali sana/contribndeb DEP-11 64×64 Icons
    Игн:33 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 Packages
    Игн:34 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all Packages
    Игн:35 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-en
    Игн:36 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru
    Игн:37 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru_RU
    Игн:38 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 DEP-11 Metadata
    Игн:39 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all DEP-11 Metadata
    Игн:40 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ DEP-11 64×64 Icons
    Игн:41 http://http.kali.org/kali sana/sana/updates amd64 Packages
    Игн:42 http://http.kali.org/kali sana/sana/updates all Packages
    Игн:43 http://http.kali.org/kali sana/sana/updates Translation-en
    Игн:44 http://http.kali.org/kali sana/sana/updates Translation-ru_RU
    Игн:45 http://http.kali.org/kali sana/sana/updates Translation-ru
    Игн:46 http://http.kali.org/kali sana/sana/updates amd64 DEP-11 Metadata
    Игн:47 http://http.kali.org/kali sana/sana/updates all DEP-11 Metadata
    Игн:48 http://http.kali.org/kali sana/sana/updates DEP-11 64×64 Icons
    Игн:49 http://http.kali.org/kali sana/contrib amd64 Packages
    Игн:50 http://http.kali.org/kali sana/contrib all Packages
    Игн:51 http://http.kali.org/kali sana/contrib Translation-ru
    Игн:52 http://http.kali.org/kali sana/contrib Translation-en
    Игн:53 http://http.kali.org/kali sana/contrib Translation-ru_RU
    Игн:54 http://http.kali.org/kali sana/contrib amd64 DEP-11 Metadata
    Игн:55 http://http.kali.org/kali sana/contrib all DEP-11 Metadata
    Игн:56 http://http.kali.org/kali sana/contrib DEP-11 64×64 Icons
    Игн:9 http://http.kali.org/kali sana/main amd64 Packages
    Игн:10 http://http.kali.org/kali sana/main all Packages
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU
    Игн:12 http://http.kali.org/kali sana/main Translation-en
    Игн:13 http://http.kali.org/kali sana/main Translation-ru
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons
    Игн:17 http://http.kali.org/kali sana/non-free all Packages
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU
    Игн:20 http://http.kali.org/kali sana/non-free Translation-en
    Игн:21 http://http.kali.org/kali sana/non-free Translation-ru
    Игн:22 http://http.kali.org/kali sana/non-free amd64 DEP-11 Metadata
    Игн:23 http://http.kali.org/kali sana/non-free all DEP-11 Metadata
    Игн:24 http://http.kali.org/kali sana/non-free DEP-11 64×64 Icons
    Игн:25 http://http.kali.org/kali sana/contribndeb all Packages
    Игн:26 http://http.kali.org/kali sana/contribndeb amd64 Packages
    Игн:27 http://http.kali.org/kali sana/contribndeb Translation-ru
    Игн:28 http://http.kali.org/kali sana/contribndeb Translation-ru_RU
    Игн:29 http://http.kali.org/kali sana/contribndeb Translation-en
    Игн:30 http://http.kali.org/kali sana/contribndeb all DEP-11 Metadata
    Игн:31 http://http.kali.org/kali sana/contribndeb amd64 DEP-11 Metadata
    Игн:32 http://http.kali.org/kali sana/contribndeb DEP-11 64×64 Icons
    Игн:33 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 Packages
    Игн:34 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all Packages
    Игн:35 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-en
    Игн:36 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru
    Игн:37 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ Translation-ru_RU
    Игн:38 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ amd64 DEP-11 Metadata
    Игн:39 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ all DEP-11 Metadata
    Игн:40 http://http.kali.org/kali sana/http://security.kali.org/kali-security/ DEP-11 64×64 Icons
    Игн:41 http://http.kali.org/kali sana/sana/updates amd64 Packages
    Игн:42 http://http.kali.org/kali sana/sana/updates all Packages
    Игн:43 http://http.kali.org/kali sana/sana/updates Translation-en
    Игн:44 http://http.kali.org/kali sana/sana/updates Translation-ru_RU
    Игн:45 http://http.kali.org/kali sana/sana/updates Translation-ru
    Игн:46 http://http.kali.org/kali sana/sana/updates amd64 DEP-11 Metadata
    Игн:47 http://http.kali.org/kali sana/sana/updates all DEP-11 Metadata
    Игн:48 http://http.kali.org/kali sana/sana/updates DEP-11 64×64 Icons
    Игн:49 http://http.kali.org/kali sana/contrib amd64 Packages
    Игн:50 http://http.kali.org/kali sana/contrib all Packages
    Игн:51 http://http.kali.org/kali sana/contrib Translation-ru
    Игн:52 http://http.kali.org/kali sana/contrib Translation-en
    Игн:53 http://http.kali.org/kali sana/contrib Translation-ru_RU
    Игн:54 http://http.kali.org/kali sana/contrib amd64 DEP-11 Metadata
    Игн:55 http://http.kali.org/kali sana/contrib all DEP-11 Metadata
    Игн:56 http://http.kali.org/kali sana/contrib DEP-11 64×64 Icons
    Ошк:9 http://http.kali.org/kali sana/main amd64 Packages
      404  Not Found
    Игн:10 http://http.kali.org/kali sana/main all Packages
    Игн:11 http://http.kali.org/kali sana/main Translation-ru_RU
    Игн:12 http://http.kali.org/kali sana/main Translation-en
    Игн:13 http://http.kali.org/kali sana/main Translation-ru
    Игн:14 http://http.kali.org/kali sana/main all DEP-11 Metadata
    Игн:15 http://http.kali.org/kali sana/main amd64 DEP-11 Metadata
    Игн:16 http://http.kali.org/kali sana/main DEP-11 64×64 Icons
    Игн:17 http://http.kali.org/kali sana/non-free all Packages
    Игн:18 http://http.kali.org/kali sana/non-free amd64 Packages
    Игн:19 http://http.kali.org/kali sana/non-free Translation-ru_RU
    Получено 18,5 kБ за 42с (433 Б/c)
    Чтение списков пакетов… Готово
    W: Репозиторий «http://http.kali.org/kali sana Release» не содержит файла Release.
    N: Данные из этого репозитория нельзя аутентифицировать, и поэтому потенциально из небезопасно использовать.
    N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.
    E: Не удалось получить http://http.kali.org/kali/dists/sana/main/binary-amd64/Packages&nbsp; 404  Not Found
    E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

     

  5. vasya kurolesovV:

    доброг времени суток народ как brug поставить в kali linux2016.2??? ПОМОГИТЕ

  6. vasya kurolesovV:

    мне удалось дойти до устоновки но вот логи те что выше написаны точь в точь

  7. vasya kurolesovV:

    да и ещо удолось запустить buc super-boot-manager 0.6 но перед ним я поставил buc 5.0 после этого все завелось но brug не становиться 🙁

  8. vasya kurolesovV:

    народ помогите тема мертвая 🙁  Где бы скачать это BRUG в tar.gz хотя бы для 64 вот блин как же его поставить?????

Добавить комментарий

Ваш e-mail не будет опубликован.